«

»

Jan 11 2018

VMware ESXi Upgrade 6.0 To 6.5 – Conflicting VIBs


A few days ago I was contacted by a customer I used to work with before I joined Nutanix. They were in the process of upgrading their vSphere environment from 6.0 to 6.5 and had ran into a problem with the ESXi upgrade.

After creating a vSphere Update Manager (VUM) baseline with the HP ESXi image VMware-ESXi-6.5.0-Update1-6765664-HPE-650.U1.10.1.5.26-Oct2017.iso they got an error during the remediation saying:

Software or system configuration of host X.Y.Z is incompatible. Check Scan results for details.

Scan result details stated the following :

  • The upgrade contains the following set of conflicting VIBs:
    Mellanox_bootbank_net-mst_2.0.0.0-1OEM.550.0.0.600000
    Mellanox_bootbank_net-mst_2.0.0.0-1OEM.550.0.0.600000

I have seen this before and it is a pretty easy fix to solve this if you’re not using Mellanox network cards. First you need to verify if you’re using Mellanox NICs unless you already know. One way of doing this is to run the below command from an ESXI host SSH session:

  • esxcli network nic list
    • The output in this case did not include any NIC using Mellanox drivers

When you have determined you are not using Mellanox drivers you can just remove the VIB from the existing ESXi host by running the following set of commands:

  • List the VIBs via the following command:
    • esxcli software vib list | grep -i mellanox
  • Remove the VIB via the following command:
    • esxcli software vib remove -n net-mst

The removal results seen in the above really poor screenshot or in the below text tells you that you need to reboot the ESXi host

Removal Result
Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
Reboot Required: true
VIBs Installed:
VIBs Removed: Mellanox_bootbank_net-mst_2.0.0.0-1OEM.550.0.0.600000
VIBs Skipped:

When the ESXi host reboot is completed you can perform the ESXi upgrade using VUM.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">